Canon autoramp is a mess after C - 2.0.0 upgrade [fixed in A2.2.3]

We tested as good as we can. But there will always be things we didn't find. If you found things that apparently don't work as they should, you can report them here so we can take care of them as soon as possible.
Posts: 43
Joined: August 27th, 2020, 8:20 am

November 17th, 2022, 7:35 am

Well, it has been more than one month... there's still no response. Apparently you don't care for the existing customers, but focus on selling your new 22' device. This is not fair.

Why do you always marked a bug as fix when it's still on going?

Here's another recent example that sunset stopped ramping:
MtHood.png (176.34 KiB) Viewed 608 times
Autoramping never worked for me since the firmware v2.0. It has wasted a lot of my time and ruined most of my vacations since last summer. I sent you an email a month ago, no response either. This is not professional at all. I was so enthusiastic about this device at the begining. I input a lot in this forum. But now I cannot stand with it any longer. There are too many defects, too many degrades, and you always ask customers to play the trial and error game, testing your changes. We cannot afford QA'ing your code with those once in a life time opportunities.

Olive, once a gain I need a refund.
Posts: 790
Joined: October 9th, 2018, 4:17 pm

November 17th, 2022, 3:53 pm

Hi Zoom,

I'm really sorry for the continued trouble!

Yes, we are currently extremely busy preparing production of the Unleashed'22, but as I explained before, this does not not at all mean we don't care about about our current Unleashed'18 customers! The opposite is true. As the two Unleashed models share all their firmware, with only certain additional features being enabled for the Unleashed'22, we have every reason to fix bugs such as the ones you are reporting.
However, we're a small team, with a finite amount of time, and very many things to do. Bugfixing is extremely important to us, but we cannot drop everything else we're currently working on to fix rare bugs, especially not if they are difficult to reproduce as that takes unpredictably large amounts of time. Making things worse, you seem to be the only one with these issues, so we have no additional information from other customers that might help to narrow down the cause of the issues you're seeing. So please send us as much information about when you encounter these bugs as you can, to help us reproduce them.

That said, and to show you we're serious about fixing bugs, we just got a 5D Mark IV, just so that we can attempt to reproduce exactly these bugs you've been seeing, as despite many tries, we have not been able to reproduce the issues on any of our other cameras that we regularly test with! This took a lot longer than expected, and is one of the reasons why I put off getting back to you for a little too long. Sorry about that.

One thing you can try is to do a factory reset on your Unleashed. Currently, this is only possible in the iOS app, under Menu -> Unleashed with gear icon -> Your Unleashed (C1: 5D Mark IV) -> Settings. Scroll to the very bottom and tap on Factory reset, and after a few seconds turn off and on the camera or unplug and replug the Unleashed.
I'm telling you this because we just had two other customers with completely unrelated issues, where this suddenly fixed their problems. This means that there seems to be something wrong with the way we save or read back one of the settings in non-volatile storage, and we'll definitely look into what that might be. Since the autoramping limits and other settings are also stored in this non-volatile storage, there's a small chance, that they might also be affected in some way, which would explain why you're having trouble that no-one else seems to be running into.

Greetings from Berlin,

PS. Please don't cross post the same info onto the other forums and threads, that is not helpful, so I have removed those posts.
Founder & CEO of Foolography, Hardware & Firmware developer.
Post Reply