Failed firmware update

We tested as good as we can. But there will always be things we didn't find. If you found things that apparently don't work as they should, you can report them here so we can take care of them as soon as possible.
Post Reply
Posts: 2
Joined: June 27th, 2022, 2:37 am

June 27th, 2022, 2:44 am

Initially started to update, got to 50% stopped and asked to restart or reboot. Choose restart. Now it either tries automatically or I hit restart and won’t go past 0%

A 2.1.3
B 2.13
C 2.0.0
Posts: 7
Joined: November 18th, 2020, 9:18 am

June 27th, 2022, 8:07 am

Sorry you're having issues with you Unleashed! Could you please supply the following info below or via our support/troubleshooting form (

Camera model*

Phone model/operating system*

Unleashed serial number (App menu → Unleashed icon in bottom left → tap on your Unleashed → at the top: “Serial Number 012345”)

Unleashed App Version (App menu → (i) → About)

Feel free to copy and paste the info below. We'll get back to you as soon as we know more!
Marketing/Communications/Operations at Foolography
Posts: 2
Joined: June 27th, 2022, 2:37 am

June 27th, 2022, 12:55 pm

Camera Nikon D610
Device iPhone 13 running iOS 15.5
Serial 000791
App-Version 2.0.2 (1773)

Thank you.
Posts: 782
Joined: October 9th, 2018, 4:17 pm

June 29th, 2022, 6:32 pm

I see that your serial number is below 4500, so we almost definitely have a fix for you. You will not believe this but the following trick will almost definitely help: Put the Unleashed in the freezer for 10-20 minutes, then plug it into the camera and try the update again, while it’s still as cold as possible.
We took a long time trying to find the cause of this problem. We found the problem and fixed it, but the fix comes in Firmware A, so if there’s ever a problem during the update of Firmware A, the fix will no longer work either.. The trick with the freezer has a scientific explanation too - now that we know the underlying cause.

Please try a few times - we've had cases where it worked only after the 4th or 5th attempt, see: viewtopic.php?f=13&t=1345&hilit=freezer

I hope it helps!
Founder & CEO of Foolography, Hardware & Firmware developer.
Posts: 9
Joined: January 23rd, 2021, 3:32 am

August 4th, 2022, 12:25 am

Update: Took a couple of times, but that fixed the issue Thanks!!

Sorry did not see the part about the freezer, and trying that now - strange stuff there.

Having the same issue with different camera

Camera model - Nikon Z6
Phone - iPhone 11 IOS 15.6
Unleashed serial number - 004375
Unleashed App Version - 2.02

Thank You,
Post Reply