Page 2 of 5

Re: Nikon D3200 & N2 not playing nicely

Posted: April 3rd, 2019, 6:37 pm
by 007
If you have a debug build apk I could install it and send you the logfile...
Or what do you suggest I'd do now?

Re: Nikon D3200 & N2 not playing nicely

Posted: April 3rd, 2019, 7:20 pm
by Liquidgoat
Unfortunately, I have not been able to find any non-retail individuals with a Nikon SLR. Everyone seems to have Canons.

The guy at Samy's Camera here would not allow me to try it on one of the in-store cameras for fear of damage.

So I am at a bit of a stopping point, here. Any other ideas?

Re: Nikon D3200 & N2 not playing nicely

Posted: April 5th, 2019, 7:26 pm
by Oliver
007: we're currently implementing some changes to the bootloader in the hopes of fixing your issue - I have a device exhibiting the same issue as yours, so we're able to test it. hopefully we'll get somewhere quick!

liquidgoat: OK. please write a quick email to support@foolography.com, requesting an RMA, and include your current shipping address we'll send you a replacement Unleashed and cable. Please test both the new cable on your current Unleashed, and your cable on the new Unleashed, so we know what the issue was.

Re: Nikon D3200 & N2 not playing nicely

Posted: April 26th, 2019, 11:34 pm
by Liquidgoat
Hi, Oliver and staff.

I received my replacement Unleashed N2 this morning -- thank you.

Identical issue with this new unit, unfortunately.

Here are the steps that I took and the photos are below:

#1 - Removed previous Unleashed N2 and previous USB cable from Nikon 3200 camera (while the camera was in the power off position)
#2 - Deleted the Unleashed App from my iPhone 6 in order to start fresh
#3 - Turned my iPhone off and then back on to make sure memory is clear
#4 - Re-installed Unleashed to my iPhone 6
#5 - Installed the replacement N2 and replacement USB cable onto my Nikon 3200 (in the power-off position) (see photo below)
#6 - Turned Nikon 3200 on. The Unleashed device LED clicks on (see photo below) - so it is getting power
#7 - Selected my replacement Unleashed N2 in the app and ran the firmware update (see screenshot of firmware below)
#8 - Tried app features with replacement Unleashed N2 with the same results as before
#9 - GPS and shutter release both work perfectly.
#10 - Tried unplugging and replugging USB - no change occurred
#11 - Plugged a USB cable into my Nikon 3200 to my computer to see if I could transfer data -- data transferred perfectly - so USB seems to work


So, unless my USB port is somehow not communicating fully with the N2, I think there may possibly be a compatibility issue with this camera?

So now I have two N2 units (one that I need to return to you), and neither is fully functional with this particular camera. Not sure what to do next.

- tim

Re: Nikon D3200 & N2 not playing nicely

Posted: May 2nd, 2019, 5:44 pm
by Liquidgoat
Any chance of a reply on my issue? Right now I am kind of dead in the water.

Thanks.

Re: Nikon D3200 & N2 not playing nicely

Posted: May 6th, 2019, 7:26 pm
by 007
I just did an app update and it found new firmwares. But I still can't update because the Unleashed immediately disconnects at update start. Also I still can only trigger a shot but do nothing else. What now?

Re: Nikon D3200 & N2 not playing nicely

Posted: May 6th, 2019, 11:30 pm
by Oliver
Liquidgoat:
Hmm, very odd.
Plugged a USB cable into my Nikon 3200 to my computer to see if I could transfer data -- data transferred perfectly - so USB seems to work
What computer and what software do you use for this test?

007: please try a couple of times! and yes, it's supposed to disconnect as soon as you start the update - the Unleashed then reboots into Firmware update mode, but the app should then reconnect immediately too, and begin the firmware update.
can you make sure you did not pair with the Unleashed in your system settings?

Re: Nikon D3200 & N2 not playing nicely

Posted: May 7th, 2019, 12:24 am
by Liquidgoat
In response to your question, I use a Macintosh Powerbook Pro (2016) running Mojave 10.14.4. I initiate USB transfers with the Nikon USB cable and Apple's native "Photos" application.

When I plug the Nikon D3200 into the computer, it immediately pops up in the Photos application and I can then transfer photos and delete photos from the camera with no issue.

(Note that the D3200 is also updated with the latest Nikon firmware).

liquidgoat

Re: Nikon D3200 & N2 not playing nicely

Posted: May 11th, 2019, 6:48 pm
by 007
Oliver wrote:
May 6th, 2019, 11:30 pm
007: please try a couple of times! and yes, it's supposed to disconnect as soon as you start the update - the Unleashed then reboots into Firmware update mode, but the app should then reconnect immediately too, and begin the firmware update.
can you make sure you did not pair with the Unleashed in your system settings?
So that's the state of the BT:
bt.png
Bluetooth state
bt.png (4.75 KiB) Viewed 945 times
And that's Your app:
app.png
App state
app.png (37.52 KiB) Viewed 945 times
With or without USB cable doesn't matter. Even after a minute the app didn't connect.

So either the Unleashed Boot mode doesn't listen for the app in this state or the app fails to create a connection to "Unleashed Boot". Maybe some logging debug build might help here, or do I need You to update the Unleashed by Your devs?

(Another question: why can't the update be aborted with the orange X?)

Re: Nikon D3200 & N2 not playing nicely

Posted: May 14th, 2019, 3:08 pm
by Oliver
007: could you try the update from another phone?

It's very odd that it doesn't reconnect, even though it's visible in the bluetooth devices (Unleashed Boot)