No connection after latest firmware update

We tested as good as we can. But there will always be things we didn't find. If you found things that apparently don't work as they should, you can report them here so we can take care of them as soon as possible.
Post Reply
Posts: 51
Joined: January 1st, 2019, 11:23 am

May 21st, 2019, 8:05 pm


after doing the latest firmware update I no longer get a connection to my Unleashed N2. Not sure what I should do now.

Before the update the Unleashed was called somewhat like my camera, so D750. Now it is called 003003. Firmware shows A 1.3.2 B 1.3.1 and C 1.3.0.

When turning on the camera, the green / yellow LEDs start to blink for 3 seconds or so, then a short red blink occurs. Those two states alternate, until roundabout after 20 seconds the camera seems to give up (no LED is blinking any more,

I tried to change the battery (more or less doing (hopefully) a hard reset, turning on/off the camera, force closing the Unleashed app, removing the Unleashed from the camera and plugging it in again. No result. The Unleashed still is not connected.

Can you help me what I should do now?

Edit (5 minutes later): The only thing I did not dry - uninstall the app and pair the Unleashed again (I wanted to do screenshots and a video first, in case it would not be able to be paired again) - now it worked. There seems to be an issue in the app?


Posts: 300
Joined: October 9th, 2018, 4:17 pm

May 21st, 2019, 10:36 pm

Hi matthias,

That is odd, and shouldn't be neccesary. I'm glad you got it to work again though. It would have probably been enough to go to the YOUR UNLEASHEDS screen, disable and re-enable the Unleashed - or unpair the Unleashed and re-pair it from there.

I will pass the info on to our Android developers though, so they can check if they can find the cause for this.

The short red blink you're seeing is a error/warning blink, and you'd get the details of what's wrong in the App. The primary error that causes this blink at the moment is that you have GPS turned on, but the Unleashed does not have (current) GPS data, and so can't pass that data to the camera. Of course if the app is not connected, then that's the reason, but it could also be that the Location permission in the phone is not granted to the Unleashed app, or the phone has bad reception - which you'd see in the app.
Founder & CEO of Foolography, Hardware & Firmware developer.
Post Reply