Page 3 of 3

Re: Firmware update failure

Posted: September 25th, 2019, 1:25 pm
by Oliver

Sorry für die Verzögerung - es gab hier eine Verwechslung der Briefkästen - wir haben letzte Woche erst die Sendung bekommen.

Ich habe eben das Update gemacht, und auf die neuste Firmware (mit permanentem Fix für das Firmware update Problem) gebracht. Ich werde noch ein paar Tests durchführen, dann wird es zurückgeschickt!

Re: Firmware update failure

Posted: October 2nd, 2019, 10:25 pm
by thg

I have a C2 dongle for 5DMKIII. I did not use if for some time. I updated the firmware last year without any problem. I tried today as I notice that there were a lot of changes. Unfortunately each time I try (I did it at least 20 times), the app crashes on my iPhone with the led turning from blue, then to red on the dongle. I tried many times without success... my iPhone 8 has been updated to the latest version of iOS this week to 13.1.2.

the dongle is correctly detected, I can change the photo settings, the gps works, but I cannot update it ...

the actual firmware is:
A 1.2.1
B 1.2.0
C 1.2.4

Re: Firmware update failure

Posted: October 4th, 2019, 11:22 am
by Oliver
Hi thg,

yes, this is a known issue - the firmware updating library broke with iOS 13. We are actually preparing the release of a new version of our app that includes a fixed library today. I hope it gets through the Appstore Approval process quickly.

Either way, you can use a friends phone (Android or iOS 10, 11 or 12) to do the update and then go back to using it with your phone. Just disable the Unleashed in your app first, or kill the app, so that the other phone can connect to the Unleashed.

Sorry for the trouble.

Re: Firmware update failure

Posted: October 4th, 2019, 7:35 pm
by klassm
As long as you don't use Android 10 ... Seems like a pattern that Foolography fails to support recent Os versions.

But congratulations - for iOS there seems to be at least the time to fix it....

What a great company ...

Re: Firmware update failure

Posted: October 8th, 2019, 3:54 pm
by Oliver
😕 Sorry klassm for your trouble.

We try to fix bugs like the one you have with Android 10, or this iOS 13 one as quickly as possible.
As I said in the other thread, we checked if it's a quick fix, and since we could not even reproduce the issue reliably, that means it's not a quick fix!

We also checked what the iOS issue was, and within minutes determined that it only required updating the firmware update library. This took a few minutes from initial investigation to fix.
Just so you know, the fix was only released yesterday, so it has taken a few days from the actual fix to the release.

And of course it's a pattern that there are problems with the latest OS Versions. When Apple and Google change the behaviour of their OS, all apps have to be adjusted to work with these changes. Some of the changes are documented and known in advance, so they can be taken care of early, but others only appear in combination with certain Phone manufacturers, User Settings, and other possible influences which we cannot anticipate or test until we get feedback from Users that noticed such issues. As soon as we do, we try to replicate the issue and go about fixing them.

Our development teams work with Sprints, and the next Android sprint starts tomorrow, with Your bug at the top of the list. As soon as we've found and fixed it, we will release a new Android app Version!

Re: Firmware update failure

Posted: October 8th, 2019, 4:23 pm
by Oliver
to end this thread on a positive note:

the latest App releases include Firmware version A1.4.1 and C1.4.0
These include the final (permanent) solution for the Firmware updating issue that have plagued a handful of Unleasheds, where updating Firmware A kept failing.

Since it only affected such a small number of Unleasheds, and even those sometimes worked, It was a very difficult issue that took months to track down! We finally found the cause of the issue, and could therefore implement a permanent fix. And since we knew the cause of the issue, we were able to replicate the problem, and test our solution. We're now confident it will never occur again.

However, there is one problem: you need to manage to update firmware A to 1.4.1 in order to enjoy this fix!
That said, since we now know exactly what the problem is, we were able to find a workaround, which has worked on nearly 100% of all cases:
Put the Unleashed in the freezer for 30 minutes or so, then try to run the update again. After that, the new update with the fix will make sure you won't need this workaround ever again! ;-)

Sorry for all those affected by the issue and thanks for everyone's patience!

Re: Firmware update failure [solved with latest update]

Posted: October 21st, 2019, 6:53 pm
by klassm
Well Oliver, 14 days later. I guess your Sprints are not longer than 14 days, are they? Still no workaround, still no fix. The Unleashed by now has been completely useless for a month. So when do you finally fix that bug?

Re: Firmware update failure [solved with latest update]

Posted: October 24th, 2019, 11:45 pm
by Oliver
As written in the other threads: hopefully todays update fixes the issue.