Help - Unleashed does not connect (again)

We tested as good as we can. But there will always be things we didn't find. If you found things that apparently don't work as they should, you can report them here so we can take care of them as soon as possible.
svbisch
Posts: 3
Joined: October 17th, 2019, 9:30 pm

October 21st, 2019, 3:02 pm

toorude wrote:
October 21st, 2019, 11:17 am
Yesterday, I tried again. And suddenly it paired and worked better than ever before. GPS tagging even worked when the app was in the background. It even worked after switching the camera off and on again for the first time....
Well that's strange. Tried mine again just now. And it works now, too!
klassm
Posts: 48
Joined: January 1st, 2019, 11:23 am

October 21st, 2019, 6:53 pm

I also tried mine - still broken (just like the past four weeks) - and Foolography does not even care about responding here. Maybe I have to stalk them on Instagram again ...
svbisch
Posts: 3
Joined: October 17th, 2019, 9:30 pm

October 22nd, 2019, 1:43 pm

svbisch wrote:
October 21st, 2019, 3:02 pm
Well that's strange. Tried mine again just now. And it works now, too!
…and… today we're back to »not working« again :-(
toorude
Posts: 32
Joined: October 20th, 2018, 12:32 pm

October 23rd, 2019, 12:56 am

svbisch wrote:
October 22nd, 2019, 1:43 pm
svbisch wrote:
October 21st, 2019, 3:02 pm
Well that's strange. Tried mine again just now. And it works now, too!
…and… today we're back to »not working« again :-(
Same here with me. Doesn't work today. this is ridiculous.....
Nikon D850 FW C1.10 LD 2.017
QStarz BL-1000ST
Google Pixel 3 Android 10
Unleashed N1 A 1.4.1 - B 1.4.5 - C 1.4.0 App 1.3.6
toorude
Posts: 32
Joined: October 20th, 2018, 12:32 pm

October 23rd, 2019, 9:04 am

toorude wrote:
October 19th, 2019, 1:20 am
I have installed the latest firmware via my wife's phone (Galaxy S9+, Android 9), there it works, but still no connection when I try to use my own Pixel 3 with Android 10 installed. It seems like an Android issue....
Yesterday I spent two hours trying to pair my new QStarz BL-1000ST with the unleashed N1 on my D850 and my wife's Galaxy S9+.
Well, what should I say.... it would not recognize the Qstarz in the "Your Accessories" screen..... is there someone out there with a functional Unleashed? I have serious doubts.... or has my Unleashed been faulty from the very beginning?
Anyway, I feel like I am screaming for help and not getting an answer...... nice meditation chamber here...
Nikon D850 FW C1.10 LD 2.017
QStarz BL-1000ST
Google Pixel 3 Android 10
Unleashed N1 A 1.4.1 - B 1.4.5 - C 1.4.0 App 1.3.6
klassm
Posts: 48
Joined: January 1st, 2019, 11:23 am

October 23rd, 2019, 9:15 am

Well - I am ~8 scream posts ahead of you :D - gallows humour....
Oliver
Posts: 282
Joined: October 9th, 2018, 4:17 pm

October 24th, 2019, 6:09 pm

I'm sorry I've been silent for a while - I completely understand your frustrations, and I'm really sorry the Unleasheds are not working as they should for you. But as long as I have nothing to say, except "Sorry - we're working on it", I would rather spend the time trying to fix the issues than write empty words here.

That said: I finally have some news for you!
We have just released a new Android App Version!
We've tested it on a Pixel 2 with Android 10 as well as an HTC phone with android 10 and both worked flawlessly.

As I've mentioned again and again, it's extremely difficult to fix errors that we cannot reproduce. And as your experiences show: It's not even a definite Android 10 or Pixel problem - after serious problems on one day, it works perfectly the next...

In the last weeks, we scoured the internet for all documented changes that happened in Android 10, as well as undocumented changes which people might have found, but could not find any that might have been related.

We went through our Bluetooth code in detail and we did find some small bugs that might leave the App in a state where it thinks the Unleashed is connected, but isn't or vice versa, but these states could only be reached through a combination of very unlikely circumstances. We completely overhauled that part of our code, and hope that for some reason your Pixel phones with Android 10 only made it more likely to reach these state, meaning that our changes would fix your issues. It would be great if you could confirm that.



And though we take your problems very seriously - 3 of you having problems, out of about 4000 Unleasheds sold does not mean that the product in itself is flawed.
But yes, updates both from Android or from us can bring new Bugs, and we are continuously working on fixing those, as well as adding new features.

and @toorude, I'm really sorry - that's on me: I didn't realize that the last Android App update only contained Firmware Version B 1.4.3, which did not yet include QStarz support. We added that in 1.4.4. We did release 1.4.4 in the last iOS App, and I thought we released an Android version at the same time, but it seems that we waited with that to try and fix the Android 10 issue at the same time.

Now we've released B1.4.5 which includes Transystem GL-770 support too, and a few improvements concerning GPS Accessory connections.

Again, sorry fixing bugs like this take time...
And sorry for the frustration...
Founder & CEO of Foolography, Hardware & Firmware developer.
Oliver
Posts: 282
Joined: October 9th, 2018, 4:17 pm

October 24th, 2019, 6:13 pm

And just for your info: writing on multiple channels (or even multiple threads in this forum) is not going to speed up how quick we can fix bugs. If anything, it slows us down, as we need to respond much more than necessary. So if you can, we'd appreciate it if you could focus on one channel. Since more than one of you have this issue, the Forum is the best place for this.
Founder & CEO of Foolography, Hardware & Firmware developer.
toorude
Posts: 32
Joined: October 20th, 2018, 12:32 pm

October 25th, 2019, 12:23 am

Oliver, I appreciate your time and answer! So I wait until the new app version will be available for download, then I'll test and report in the forum!
Nikon D850 FW C1.10 LD 2.017
QStarz BL-1000ST
Google Pixel 3 Android 10
Unleashed N1 A 1.4.1 - B 1.4.5 - C 1.4.0 App 1.3.6
klassm
Posts: 48
Joined: January 1st, 2019, 11:23 am

October 25th, 2019, 7:01 am

Hey Oliver,

Thanks for the update. Google provided me the download 5 minutes ago, so I directly tried it out.

What should I say? It still does not connect.

I tried it 5 minutes. Once the app crashed in between. I've sent a bug report on that.

But it looks like the connection is still broken.

Sorry for the bad news.

Matthias

Edit: I've asked before - is there any way to provide you some logs? Obviously you cannot reproduce the failure, so without logs it's quite difficult to fix ...
Post Reply