Unstable app-camera connection [solved]

We tested as good as we can. But there will always be things we didn't find. If you found things that apparently don't work as they should, you can report them here so we can take care of them as soon as possible.
Post Reply
skwerl
Posts: 7
Joined: November 20th, 2018, 4:38 pm

November 20th, 2018, 5:00 pm

Hi. I received my new Unleashed N1 yesterday and I am having some trouble with it. The app seems to lose its communication channel with the device and is unable to recover it.

Hardware:
Nikon D810
Samsung Galaxy Note 4
Unleashed 2018 N1
USB is plugged in to N1 and camera body

Symptoms:
After the app connects to the N1 and the UI is enabled with turquoise indicator dot
• I can take a few shots using the phone before the app UI turns gray and the connection indicator dot turns red.
• I can take a couple shots using the camera’s trigger button and the app grays out and dot turns red.
• The UI never recovers.
• The LED on the N1 continues to pulse turquoise, indicating a connection, even when the app’s indicator dot is red.
• If I turn off the camera during this time when the indicator dot in the app is red, the app UI changes, suggesting it notices that there is no Bluetooth connection at that point. If it were a Bluetooth signal issue, I would expect the app to not react to the absence of the camera after the indicator dot turns red.

Workaround:
• If I shut the camera off, kill the app, and then start both, it will begin working again and I can take a few shots before the connection indicator on the app turns red again.


Is there something you recommend I try for troubleshooting, or does this sound like it could be a bad N1?

Thank you,
Josh Usovsky
Gasper
Posts: 4
Joined: October 5th, 2018, 9:35 am

November 21st, 2018, 9:39 am

Hi Josh,

We're sorry you're experiencing these issues. The android app is still sometimes having some connection issues (on which we're working to resolve), so I would like to confirm whether what you're experiencing is a hardware or an app issue (and help us narrow it down for your case).

So, if possible could you:
  • When you get the issue, if you just kill the app (also swipe from recents list), the UNLEASHED should not be connected (yellow slow blinking). After that, if you start the app again, does the UI recover when it connects to the UNLEASHED?
  • When you get the issue, if you go to YOUR UNLEASHEDS screen (the bottom left icon in the menu with the unleashed with a gear icon) and back to photo, does the UI recover?
  • When you get the issue, if you go to YOUR UNLEASHEDS screen and disable and enable the UNLEASHED, does the UI recover?
Gasper
Firmware & Android developer at Foolography
Andy
Posts: 107
Joined: October 4th, 2018, 4:18 pm

November 21st, 2018, 10:09 am

Hey Josh,

If you have the possibility, could you also test the Unleashed with an iOS device? Just to confirm that your Unleashed works.
Andy
Firmware developer at Foolography
skwerl
Posts: 7
Joined: November 20th, 2018, 4:38 pm

November 29th, 2018, 3:59 pm

Hi, Gasper. Sorry for the slow response time. Had a holiday and some busy days recently and haven't had a chance to troubleshot.

[*]If I kill the app, the LED on the N1 pulses turquoise.
[*]If I go to the Your Unleasheds screen and then back, occasionally it will recover, but usually only for a second or two- I've never been able to take another shot after trying this because it dies too quickly.
[*]When I try to enable/disable my detected Unleashed, nothing happens. I can tap on the yellow toggle control over and over, but it never visually changes state.

I will try to find someone with an iOS device and report back today.

Thank you,
Josh Usovsky
Oliver
Posts: 411
Joined: October 9th, 2018, 4:17 pm

November 29th, 2018, 5:42 pm

Hi skwerl,
could it be that you paired the Unleashed from your phone's Bluetooth settings before pairing it in the app?
With Bluetooth Low energy, this is not necessary, and can even cause problems.

Try to unpair the Unleashed from the Buetooth settings, and see if that helps!
Founder & CEO of Foolography, Hardware & Firmware developer.
skwerl
Posts: 7
Joined: November 20th, 2018, 4:38 pm

November 29th, 2018, 5:50 pm

Thank you for the speedy reply, Oliver. Initially I did not pair the device with the phone outside the app, but doing that was one of the things I eventually tried. I unpaired it later and just verified that it is not paired with the device anymore, however, so this doesn't seem to be the case. :/

Thank you,
Josh Usovsky
skwerl
Posts: 7
Joined: November 20th, 2018, 4:38 pm

November 29th, 2018, 8:13 pm

I just tried using it on someone's iPad, and the connection was rock solid and performed flawlessly. At this point, I'd say my issue must be that Android connection problem. Apparently it is especially bad on my Android device, because Unleashed is basically unusable with it. I'm now really looking forward to that firmware/software update!

Thank you,
Josh Usovsky
skwerl
Posts: 7
Joined: November 20th, 2018, 4:38 pm

December 13th, 2018, 8:03 pm

Hi, guys. Are you still thinking you will release an update before Christmas? I don't mean to push, but wondering if I should order an external shutter release or not.

Thank you,
Josh Usovsky
Andy
Posts: 107
Joined: October 4th, 2018, 4:18 pm

December 14th, 2018, 3:04 pm

Hi Josh,

I think the Android guys are planning on submitting a beta update today, and I'm told the plan is to release the actual stable update for everyone next week.
Andy
Firmware developer at Foolography
skwerl
Posts: 7
Joined: November 20th, 2018, 4:38 pm

December 14th, 2018, 3:59 pm

Thanks for the update, Andy. That's great news. I look forward to it.

Thank you,
Josh Usovsky
Post Reply