Only Photo mode works on N2 and Nikon D750 [solved - hardware defect]

We tested as good as we can. But there will always be things we didn't find. If you found things that apparently don't work as they should, you can report them here so we can take care of them as soon as possible.
Adrian
Posts: 4
Joined: November 21st, 2018, 4:17 pm

November 29th, 2018, 5:12 pm

Please tap on any of the camera settings to wake up the Unleashed, to me it seems that is currently in standby mode (judging from the screenshot). After it's no longer in standby you should see your current camera settings. If you get to that point please take another screenshot and post it here, it may help us find the root of the issue you experience with your camera.
Adrian
📱 iOS developer at Foolography
hyy
Posts: 27
Joined: November 26th, 2018, 7:01 pm

November 29th, 2018, 6:12 pm

OK, several things I'm noticing.

1. The GPS is the only setting that is consistently enabled -- I can change the settings on it. I can trigger the shutter from the app. even when all the other settings are not enabled or lit up.

2. I was able to tap around several times and got several other settings lit up and felt haptic feedback on the phone. But I could only do this once. What I'm seeing consistently is that toggling the power button on the camera causes the other Photo settings to become enabled.

However, Unleashed app. still thinks the camera is shooting when I tap for instance the focus mode (see screenshot attached).

And as soon as I trigger a photo from the app., the camera preview shows it was taken, with geotag. But the Unleashed app. thinks it's taking another picture and all the settings, other than GPS, become disabled again.

As I noted, even with only GPS setting lit up in the app, the shutter is working, so that seems to contradict the other part of the app. which thinks the camera is still taking the shot.

Those messages about the camera still taking a picture are nonsensical, since most of the time, the shutter speeds are fractions of a second. My camera takes a picture in bright light and it's ready for the next one.
IMG_3760.PNG
IMG_3760.PNG (200.9 KiB) Viewed 1422 times
Regardless of some software status it may return, it's at odds with the physical state of the camera, which is that I can take new pictures, while the app. thinks it's still taking the first one.

3. So I have to keep toggling the power button to get the other settings in Photo mode enabled or wake the Unleashed device.

4. Even with several but not all the settings in Photo mode enabled, Video and Time Lapse modes still report that the camera is taking a picture, just as tapping on some of the Photo settings return that message.
IMG_3760.PNG
IMG_3760.PNG (200.9 KiB) Viewed 1422 times
Andy
Posts: 104
Joined: October 4th, 2018, 4:18 pm

November 29th, 2018, 7:00 pm

Is the yellow ring of the trigger button in the app always there? Can you perform some tests for me and check the following scenarios?
  • Turn camera off and on again and check if the trigger is still yellow.
  • If the trigger isn't yellow after turning the camera on, check if triggering from the camera makes the trigger stay yellow.
If the trigger remains yellow only after triggering from the app, then it may be a firmware issue, but I still doubt it.

What do you mean with this?
hyy wrote:
November 29th, 2018, 6:12 pm
So I have to keep toggling the power button to get the other settings in Photo mode enabled or wake the Unleashed device.

It seems to me that your Unleashed is working mostly fine, but the yellow ring in the trigger is causing issues in the app. It may be a hardware issue.
Andy
Firmware developer at Foolography
hyy
Posts: 27
Joined: November 26th, 2018, 7:01 pm

November 29th, 2018, 7:11 pm

Most of the time it seems to be yellow.

I could quit the app and force it to reload by up swiping it as a running app, Then when it launches, it's gray with all the settings disabled.

But once I start tapping on the settings, it turns yellow and stays there.

When you say hardware issue, are you saying hardware issue with my camera or the Unleashed device?
Andy
Posts: 104
Joined: October 4th, 2018, 4:18 pm

November 29th, 2018, 7:16 pm

If after the Unleashed connects to your phone, you turn on the camera and the yellow ring is there, I'd say that your Unleashed has an issue with the shutter detection. Unfortunately, that would be a hardware issue, more likely in the Unleashed than in the camera.

One thing that you can do to confirm that the Unleashed is faulty is to connect it to another Nikon camera with a square plug. If the app still shows the yellow ring, then it's definitely an issue with your Unleashed.
Andy
Firmware developer at Foolography
hyy
Posts: 27
Joined: November 26th, 2018, 7:01 pm

November 29th, 2018, 7:19 pm

I don't have another Nikon.

I may buy a Z7 but I don't know if it has a square plug.
Andy
Posts: 104
Joined: October 4th, 2018, 4:18 pm

November 29th, 2018, 7:20 pm

It does.
Andy
Firmware developer at Foolography
hyy
Posts: 27
Joined: November 26th, 2018, 7:01 pm

November 29th, 2018, 7:23 pm

OK if I buy it or get access to another Nikon DSLR somehow and it has the same behavior, then it would implicate the Unleashed?

What is the warranty period, a year?
Andy
Posts: 104
Joined: October 4th, 2018, 4:18 pm

November 29th, 2018, 7:25 pm

You could take the Unleashed with you the next time you're around an electronics store and test the Unleashed with one of the cameras there. Also if anyone you know has a Nikon camera you could test on, that would also be helpful.

Otherwise, maybe we could disable the feature in the app that "disables" the other modes when the yellow ring is there. But I don't know, we have to evaluate the case.
Andy
Firmware developer at Foolography
Andy
Posts: 104
Joined: October 4th, 2018, 4:18 pm

November 29th, 2018, 7:27 pm

Yes I think the warranty period is one year, but for more info on that I'd recommend you to send an email to support@foolography.com. I don't really know how the warranty stuff is handled.
Andy
Firmware developer at Foolography
Post Reply