Android crashes when connecting to Device [solved - turn on GPS]

We tested as good as we can. But there will always be things we didn't find. If you found things that apparently don't work as they should, you can report them here so we can take care of them as soon as possible.
Post Reply
mbofotografie
Posts: 1
Joined: December 23rd, 2018, 2:20 pm

December 23rd, 2018, 2:30 pm

Since the new Update i am facing the Problem, that my HTC U11 (Android 8.0) crashes when i connect to the unleashed adapter.

The behavior is always the same:
Open the Unleashed ap and everything is fine.
Plug in the adapter to the Camera and then try to connect in the app...

The device is shown, but just in the moment the connection will be established the app crashes and then device stuck in a Cycle of poweroff and poweron the screen.
The only possibillity is to shutdown the mobile completly, or perform a reeboot.


I tried to set my device to factory defaults, but it does not fix the issue.
Then we tried the Phone of a friend and there it works perfect.

Technical Facts:
HTC - U11
Android 8.0
Settings are in factory default

Camera Nikon D800
nworx
Posts: 1
Joined: January 28th, 2019, 1:37 am

January 28th, 2019, 1:40 am

hi
I'm facing the exact same problem.
as soon as my android device tries to connect it ends up in a loop and i have to reboot my phone.

Android: HTC 10
Camera: Nikon D7200
Oliver
Posts: 241
Joined: October 9th, 2018, 4:17 pm

January 30th, 2019, 4:42 pm

We answered mbofotografie via email, just in case anyone thought we don't care - we do!

That's very odd, and unfortunately if the phone crashes, we don't get any crashlogs, so it's also very difficult to debug.

We will try to get our hands on an HTC 10 or U11 to replicate the issue, it seems to have something to do with a low-level HTC Bluetooth driver or something similar...

@nworx: can you specify which android version you're running?

on other phones (Sony Z series) a bluetooth issue was fixed by resetting the network settings in Android - see if that helps!
Founder & CEO of Foolography, Hardware & Firmware developer.
Oliver
Posts: 241
Joined: October 9th, 2018, 4:17 pm

May 21st, 2019, 4:31 pm

So we finally found the exact cause of the issue:

Oddly, Android requires location permission to search for Bluetooth devices the way we do - why they merged the permissions for this, we're unsure - probably because some Bluetooth beacons can be used to calculate a position, and this type of scanning therefore can enable determining a location, even though it usually doesn't. It's certainly confusing for the Consumer!

However, it seems that this did not just confuse Consumers, but even some manufacturers. They don't just require the location permission (which we request from the user in a pop-up in the app), but also require the location service to be turned on at the highest precision, ie GPS + Wifi + Cell tower positioning.

We will try to add a check for HTC, and ask the user to enable GPS as well as granting the permission to use location, so that this error should be gone entirely, and certainly won't crash the phone anymore. But until then, just turn on GPS, and you should be fine. This in only needed while searching for Unleasheds to pair. Once paired, you can turn it off again - reconnecting works without these permissions.
Founder & CEO of Foolography, Hardware & Firmware developer.
Post Reply