Thumbnail review not working in BETA-3 [fixed in Beta 4]

Bugs and Issues only for the Beta version of our apps and firmware
Unfoolishly
Posts: 297
Joined: June 24th, 2020, 2:43 am

October 6th, 2021, 1:37 am

Hi All,

The thumbnail review isn't working at all. After you turn this option ON and take one or two photos, the whole UI elements for this feature are gone from the UI.
All photos end up black (not viewed). But I do see some BT upload circle with upload percentages.

More details follow up later on.

Can you test and confirm this on your part?

Greerings,
Unfoolishly
Retired customer of the Unleashed. I have given up on this project, it's a never-ending story of bugs. Goodbye everyone!
Unfoolishly
Posts: 297
Joined: June 24th, 2020, 2:43 am

October 6th, 2021, 12:07 pm

Update:

Process:
1. turn ON thumbview.
2. take photo.
3. see that the thumbview is uploaded (circle showing upload in %)

Three options now:
4a. thumbview is shown (thumbview photo very dark while photo isn't!)
4b. thumbview is shown (thumbview photo normal, thumbview same as photo)
4c. thumbview is NOT shown (all black, no thumbview shown)

5. restarting the App doesn't help. Uninstalling App and installing App also not.
6. Option to turn on/off thumbview no longer available. Button no longer responding.

By the time I discovered this, my first reaction was: who is doing the programming at Foolography? Because it sure isn't a senior developer messing this feature up.

Oh boy, what a mess: fix something here, break something there. Not very "professionally" imho.

Please fix this ASAP! It is getting ridiculous now.

Snapshots:
Screenshot_20211006-114204.png
Screenshot_20211006-114204.png (94.09 KiB) Viewed 1778 times
Screenshot_20211006-114249.png
Screenshot_20211006-114249.png (95.74 KiB) Viewed 1778 times

Greetings,
Unfoolishly
Retired customer of the Unleashed. I have given up on this project, it's a never-ending story of bugs. Goodbye everyone!
Unfoolishly
Posts: 297
Joined: June 24th, 2020, 2:43 am

October 6th, 2021, 12:33 pm

More snapshots:
Screenshot_20211006-121916.png
Screenshot_20211006-121916.png (97.27 KiB) Viewed 1775 times
Screenshot_20211006-121958.png
Screenshot_20211006-121958.png (95.19 KiB) Viewed 1775 times
Screenshot_20211006-122028.png
Screenshot_20211006-122028.png (97.19 KiB) Viewed 1775 times
Thumbnail/view was uploaded, but screen is black. I did see a upload circle.
I am sure it isn't the BT problem as before with the old FW. I am quite sure it is the App not functioning correctly.
Retired customer of the Unleashed. I have given up on this project, it's a never-ending story of bugs. Goodbye everyone!
Unfoolishly
Posts: 297
Joined: June 24th, 2020, 2:43 am

October 6th, 2021, 12:35 pm

More snapshots:
Screenshot_20211006-122132.png
Screenshot_20211006-122132.png (101.25 KiB) Viewed 1774 times
Screenshot_20211006-122456.png
Screenshot_20211006-122456.png (100.34 KiB) Viewed 1774 times
Logging:
2021-10-06-12-21-45.zip
(71.3 KiB) Downloaded 78 times
That's it for now.
Retired customer of the Unleashed. I have given up on this project, it's a never-ending story of bugs. Goodbye everyone!
Oliver
Posts: 727
Joined: October 9th, 2018, 4:17 pm

October 6th, 2021, 1:03 pm

We have reworked this entire screen and fixed several bugs related to the thumbnail view. We hadn't seen exactly what you are seeing, but will look at your logs to see if we can find a possible cause.

Hmm, the Log is showing that it failed to save some of the files (IO Exception). That's an error from the filesystem.
Very interesting that it worked sometimes and then doesn't another time. 😕

We'll look into it.
Founder & CEO of Foolography, Hardware & Firmware developer.
Unfoolishly
Posts: 297
Joined: June 24th, 2020, 2:43 am

October 6th, 2021, 1:45 pm

I experienced these scenarios:

Take photo using the camera and then...
A) thumbview uploading but black at the end... and Thumbview not working anymore from the UI in the App
B) thumbview uploading but half viewed... and Thumbview not working anymore from the UI in the App
C) thumbview uploading and shown in the App, but too dark compared with the original on the camera view (back panel)
D) thumbview uploading and shown in the App, and same as original on the camera view (back panel) but of course compressed/lower quality.

It should only be option D) constantly. I now get at random A, B, C or D, when option D is not the most predictable situation :(

Notice the different icons of the thumbview icon in the lower right corner of the App.
Something is messed up, that's for sure!

And no, it's not because of memory shortage. Storage is not the problem.

I think you need to create a dedicated thumbview screen, next to the UI space within the operations/controls view of the App. It will give the user more options than only turn on/off and swipe left/right to see the thumbnails.

Snapshot:
Screenshot_20211006-133252.png
Screenshot_20211006-133252.png (103.32 KiB) Viewed 1768 times
Greetings,
Unfoolishly
Retired customer of the Unleashed. I have given up on this project, it's a never-ending story of bugs. Goodbye everyone!
Unfoolishly
Posts: 297
Joined: June 24th, 2020, 2:43 am

October 6th, 2021, 1:50 pm

Oliver wrote:
October 6th, 2021, 1:03 pm
Hmm, the Log is showing that it failed to save some of the files (IO Exception). That's an error from the filesystem.
Maybe this is because of the location where the thumbnails are stored on the device/smartphone?
I noticed that the space of the Unleashed App grows from time to time from 7,68 Mb to 57 MB, but when I uninstalled and reinstalled the App it was back to 7,68 Mb.
Maybe the App isn't flushing the log files after an on/off switch? Same goes for the thumbnails...

Tip: I have never seen the Unleashed App ask me the storage location for the thumbnails? Maybe you need to ask the user where to put those thumbnails and don't store them in the App space of the device?

I think the BT uploading itself is now not the real problem. I think it is the App and the permissions to store the thumbnails somewhere else (not in the App space itself).

Greetings,
Unfoolishly
Retired customer of the Unleashed. I have given up on this project, it's a never-ending story of bugs. Goodbye everyone!
Unfoolishly
Posts: 297
Joined: June 24th, 2020, 2:43 am

October 6th, 2021, 3:34 pm

Just my humble opinion:
If something fails in the Unleashed App, the user should be informed about this, and also the reason behind the failing, because there are a few options that the user must be made aware of, and these are:
1. User error: user tries to accomplish something but is not working according to operational guidelines. A.k.a.: user does stupid things :-)
2 Unleashed App error: the App tries to accomplish something but is failing in doing so. Can the user be provided with alternatives from the App, by the App?
3. Unleashed hardware error: the Unleashed tries to accomplish something but is failing in doing so.
4. Camera error: the camera tries to accomplish something but is failing in doing so.

The App should at least give some more clues in an overview screen (human readable logging?) so that the user can figure out what he/she or the equipment is doing wrong?

Just my 2cts.

Greetings,
Unfoolishly
Retired customer of the Unleashed. I have given up on this project, it's a never-ending story of bugs. Goodbye everyone!
Oliver
Posts: 727
Joined: October 9th, 2018, 4:17 pm

October 6th, 2021, 5:13 pm

I have tried to tell you before:
If there is a bug, then there is no way of identifying this bug in advance and making preparations that the user gets informed about this bug, all the details surrounding it and what he needs to do it to get around it.

If we had any of that information, would you rather we add this bug to a list known bugs and all sorts of info about it into a human readable UI to present to the user... Then do an app & firmware release with the bug added to the list of known bugs. 🤨 Or would you rather we just fix it? I can promise you that fixing it would be faster.

What you suggest would be OK for some known Hardware issues that can come up. where if we detect them, we could inform the user. But it's impossible for unknown bugs!
Founder & CEO of Foolography, Hardware & Firmware developer.
Unfoolishly
Posts: 297
Joined: June 24th, 2020, 2:43 am

October 6th, 2021, 6:30 pm

Hi Oliver,

No, you are missing the clue here. You read something into it that I don't mean and not have written.

Can a user recover from a bug? No!
Can a user recover from an IO Exception? No!
Must the user be informed that an IO Exception occurred? Yes!

The main question that must be addressed is: What feedback does the user get back from the App/Unleashed/Camera in order to let him/her know some action is needed to fix, to overcome or to ignore, or to write to Foolography about a bug...

The App could have reported back to the user something wrong with the storage of thumbnails, at least some info that tells the user: it ain't you, please look at the (human readable) logging within the App screen to troubleshoot. I got nothing to figure out why the Thumbnails weren't working, besides some dark - all black - photos. That's weird! But the encrypted logging tells YOU: IO Exception. But the user has NO information at all!
Maybe some useful event driven logging in human readable format would help out a lot for all users, not just me. Something like this:

Logging in a log screen (in human readable format):
2021/10/06;17:52:30;Photo taken from camera.
2021/10/06;17:52:32;Uploading thumbnail of photo started
2021/10/06;17:52:38;Uploading thumbnail of photo completed
2021/10/06/17:52:45;Thumbnail displayed in control screen.
2021/10/06;17:52:48;Photo taken from camera.
2021/10/06;17:52:50;Uploading thumbnail of photo started
2021/10/06/17:52:52; IO error: storage problem
2021/10/06;17:52:54;Uploading thumbnail of photo failed

That is what I am looking for as a user when something is not working as expected.
Then at least I know as a user: I don't have to bother figuring out what I AM doing wrong, because it AIN'T me!

How can I figure out my car's engine suddenly stopped working? At least I have some signalling/logging to help me out what it is that caused the car to stop suddenly: oil level okay? enough gasoline? handbrake off? etc.

All I have is: screenshots :( :( :(

You need to give us something more than that. A logging screen that shows the last 50 or 100 events (in human readable format) would be really helpful.

Consider this logging:
2021/10/06;17:52:30;Accessory connected to Unleashed 05328.
2021/10/06;17:52:32;Accessory identified as: QStarz BT-1000ST.
2021/10/06;17:52:38;Unleashed receiving GPS data.
...
...
...
2021/10/06;18:30:50;Accessory disconnected from Unleashed 05328.
2021/10/06/18:50:52; Unleashed receiving NO MORE GPS data.
2021/10/06;18:50:55;Unleashed switching to GPS data from smartphone.

That is the kind of data I would see coming by in the logging.

As a user I am not interested in this kind of logging:

Exception in thread "main" java.lang.NullPointerException: Fictitious NullPointerException
at StackTraceExample.method111(StackTraceExample.java:15)
at StackTraceExample.method11(StackTraceExample.java:11)
at StackTraceExample.method1(StackTraceExample.java:7)
at StackTraceExample.main(StackTraceExample.java:3)

That doesn't ring a bell for ANY customer!

You really need to have such logging within your App, because the user MUST be able to quickly detect: can I recover from this? Can I adjust something? Can I do something else to fix the problem? Or do I just report this bug to Foolography? (The latter means ONE action of the user: report the bug by sending the log!)

What I now do not know is this:
- Is the Unleashed sending the thumbnail correctly to the App? If not, maybe try another Unleashed?
- Is the Unleashed App receiving the thumbnail for 100% or for less than 100%? Could be a BT problem. Should I toggle flightmode or BT on/off?
- Is my storage on the phone enough? Should I free some data?
- Did I turn the thumbnail preview accidentally off? Can't turn it on/off anymore, why is that?
- Etc...

Same as for the firmware update process...
I want to be able to READ in the logging screen the following sentence:

2021/10/06;18:30:50;Firmware A update completed, now rebooting.
2021/10/06;18:31:00;Unleashed rebooting completed.
2021/10/06;18:32:30;Unleashed connected to Unleashed App. All functioning normal.

See what I mean?

If something isn't working right in the UI screens, you still have the Logging screen to peek under the hood of the App. Not in a deep technical way, but in a user friendly way!
Oil level = okay!
Gasoline level = okay!
Key on full contact = okay!
Battery full = not okay!

That's what I mean!

I don't have that. No oil meter, no gasoline meter, no battery meter, nothing.. besides GUESSING and ASSUMING.
Not really helpful.

The question process when a bug is discovered, is this:
1. Is it me? Yes, stupid me!
2. Is it me? No, what is it then?
3. Is it the camera?
4. Is it the Unleashed?
5. Is it the App?
6. Is it the Accessory?

Etc?

That's my whole point!

*sigh*

Greetings,
Unfoolishly
Retired customer of the Unleashed. I have given up on this project, it's a never-ending story of bugs. Goodbye everyone!
Post Reply