No GPS data in External GPS + Smartphone Fallback Mode. (App says OK) [fixed in Beta 4]

Bugs and Issues only for the Beta version of our apps and firmware
Unfoolishly
Posts: 293
Joined: June 24th, 2020, 2:43 am

October 10th, 2021, 6:54 pm

Hi All,

Well, this weekend another new adventure of "What is happening now again with the Unleashed and Unleashed App?". It seems to be repeating too much, all these new adventures with the BETA App....
It kinda pops up the question in my mind: is this ever going to be solved or are we staying posting new forum messages each time bringing up new problems week by week? It's getting ridiculous now. Fix something here, break something there. It is getting therapeutic by now! Please SOLVE this, once and for all!

Here is what happened this weekend. Going to a restaurant for a diner. Yes, I know... in covid-19 time that is almost a totally new experience :(

Note: All devices enough battery life. USB connector connected between Unleashed/Camera.

Process:
1. Start BETA Unleashed App on smartphone.
2. Turn on Camera.
3. See that Unleashed is having a green LED. GPS provided by smartphone only.
4. App indicates that Unleashed is connected between smartphone and Unleashed.
5. App has controls active, App tells me GPS data is send to Unleashed. (is that really true, or is it just text making me believe so?)
6. I look at the LCD backpanel of the camera: no GPS icon (strange!)
7. I look at the top Android menu of the smartphone, text says: sending GPS data.
8. I look at the Unleashed LED: green, but sometimes in between a red flash. (strange: App tells me: I am sending the GPS data, Unleashed tells me: what GPS data? Camera confirms: what GPS data?)
9. I look again at the top Android menu icons: Location icon on/off/on/off/on/off.... (strange)
10. I sit in an open terrace environment (of course with patio heating) at the restaurant (which is in a fixed pretty open space to have good GPS reception), I take a picture: NO GPS DATA! WTF???

Now you tell me: what is going on with this BETA App, because ONE of these usual suspects is LYING to me! And it ain't the camera!

See photo's, snapshots and log file. All including in this forum post. Photo's of smartphone taken at home (I don't carry TWO smartphones with me)

It's time you get this fixed once and for all, because I am really tired of the longsuffering I have to go through helping you guys help me to get a product that just WORKS out of the box. I think I have been VERY patient, but it is getting ridiculous now. This just should have worked!

2021-10-09-05-22-57.zip
no-gps-data1.jpg
Screenshot_20211010-020524.png
Greetings,
Unfoolishly
Retired customer of the Unleashed. I have given up on this project, it's a never-ending story of bugs. Goodbye everyone!
Unfoolishly
Posts: 293
Joined: June 24th, 2020, 2:43 am

October 10th, 2021, 7:02 pm

More snapshots:
Screenshot_20211010-020600.png
Screenshot_20211010-020729.jpg
Screenshot_20211010-020833.jpg
Notice: camera on and camera off: same results! Sending location / gps data.
NOT TRUE!
Retired customer of the Unleashed. I have given up on this project, it's a never-ending story of bugs. Goodbye everyone!
Unfoolishly
Posts: 293
Joined: June 24th, 2020, 2:43 am

October 10th, 2021, 7:09 pm

I am getting headaches from this. A commercial product that I need to BETA test myself, so the manufacturer can fix the problems. Normal unsatisfied customers just ask for a refund because it isn't working as advertised in the first place.

Do you think this will ever be fixed, because I am doubting now openly if it ever will be solved for good, once and for all.
And no, it is not PEBKAC!

Check the logs yourself!

Greetings,
Unfoolishly
Retired customer of the Unleashed. I have given up on this project, it's a never-ending story of bugs. Goodbye everyone!
Oliver
Posts: 727
Joined: October 9th, 2018, 4:17 pm

October 10th, 2021, 7:12 pm

Did you actually take a photo?
I have explained before that not seeing the GPS icon does not mean that you won't have GPS in your photos!

I'm not saying that there definitely is no problem, there is of course still a chance for error.
But what you are describing is not "proof" that the camera is not getting GPS data, it just means that it's not getting GPS data in that instant. We often stop sending GPS data to the camera on purpose, so that would be expected.

Try half pressing the shutterbutton, try triggering from the camera, and see if there is GPS data in your photos!

Are you using the USB cable? If not, and you have the app open, we actually have to turn off GPS in order to be able to get and set settings. but as soon as you trigger from the app, we will turn off the protocol to get and set settings, turn on GPS, then trigger the camera. Unless of course you have GPS priority set to trigger, then we won't delay the trigger to wait for a complete set of GPS data to get to the camera. Please see our Howto on Geotagging to learn more.
Once your app is in the background again, (or if you're using the USB cable), then we turn off the settings protocol over the accessory terminal, and can keep sending GPS data.
Founder & CEO of Foolography, Hardware & Firmware developer.
Unfoolishly
Posts: 293
Joined: June 24th, 2020, 2:43 am

October 10th, 2021, 7:47 pm

App was running and on the foreground.
Smartphone in range of the Unleashed.
Location of the restaurant was open so GPS data should have been received by smartphone. Location even by WiFi network possible.
App tells me the Location data sent to Unleashed. I hope I can TRUST what I read in the App!
No yellow triangle in the App, no red GPS icon in the App. All seemed to work.
I expect it to work. But it didn't! :( :( :(

We let the waiter/server take the photo's, so he is to blame for all this (just kidding).

No GPS data :(

This worked in the 1.4.2. FW / App, but now it doesn't????????
Weird!

Must be the Android App, or the FW! Seriously!

Greetings,
Unfoolishly
Retired customer of the Unleashed. I have given up on this project, it's a never-ending story of bugs. Goodbye everyone!
Unfoolishly
Posts: 293
Joined: June 24th, 2020, 2:43 am

October 11th, 2021, 12:23 am

Maybe I am on to something....

Try these scenarios:
A) Set GPS data source to smartphone only. Does the Unleashed and Camera have GPS?

B) Set GPS data source to smartphone and external GPS device (= turned OFF). Does the Unleashed and Camera have GPS?

C) Set GPS data source to smartphone and external GPS device (= turned ON). Does the Unleashed and Camera have GPS?

My guess is:
A) does work
B) does NOT work
C) does work

Try it yourself!

Possible problem: fallback mechanism in Unleashed does NOT work when switch from external GPS device to smartphone, and/or vise versa.
I think / assume this is my case scenario! That is why my photos weren't tagged!

If the external GPS device is for some reason not providing GPS data to the Unleashed, the Unleashed ALSO ignores the incoming GPS data from the App.
App signals that it is sending GPS data to Unleashed, but Unleashed complains by flashing red LED that it has problems with the external GPS device. And therefore does not send the GPS data received from the App towards the camera. But should have done just that!

REQUEST: make the LED flashing red different in numbers of flashing to distinguish between GPS data source smartphone (flash just ONE time RED), and between GPS data source external GPS device (flash TWO times RED). At least THAT way, the user can distinguish ABOUT what the Unleashed is complaining.

Should have worked anyhow, but it didn't :(

Greetings,
Unfoolishly
Retired customer of the Unleashed. I have given up on this project, it's a never-ending story of bugs. Goodbye everyone!
Unfoolishly
Posts: 293
Joined: June 24th, 2020, 2:43 am

October 11th, 2021, 12:58 am

Is there in the App a difference between:
1) GPS from smartphone OVER GPS from external GPS receiver.
2) GPS from external GPS receiver OVER GPS from smartphone.
3) GPS from smartphone AND GPS from external GPS receiver COMBINED.

There is no manual so I have to GUESS what the App icons mean.
Maybe it is wise to have the icons indicate what the user prefers: 1, 2, or 3 on how the Unleashed handles the incoming GPS data.
Why should the Unleashed flash a RED LED when it DOES receive valid GPS data? I would think that it should start flashing the RED LED only when there is something wrong and causes the user to not have the photo's geotagged. I don't care when I have set the Unleashed App GPS settings to 1) and that the external GPS device is inactive/out of range or off. As long as the GPS data is tagged inside the photo's.

Now it wasn't!

Greetings,
Unfoolishly
Retired customer of the Unleashed. I have given up on this project, it's a never-ending story of bugs. Goodbye everyone!
Unfoolishly
Posts: 293
Joined: June 24th, 2020, 2:43 am

October 11th, 2021, 2:25 am

Here it is:
Screenshot_20211011-021726.jpg
The problem is that when you selected BOTH smartphone AND external GPS device, the GPS data is NOT forwarded to the Camera! If you select smartphone ONLY the Camera does get the GPS data forwarded and the GPS icon lights up on the LCD backpanel of the Camera.

That is a silly bug! Really! *face palm*

Please fix this asap, because it is very annoying to got stuck with this bug. ALL photos NOT geotagged just because of this. Frustrating!

Greetings,
Unfoolishly
Retired customer of the Unleashed. I have given up on this project, it's a never-ending story of bugs. Goodbye everyone!
Unfoolishly
Posts: 293
Joined: June 24th, 2020, 2:43 am

October 11th, 2021, 3:06 am

Also:

Could you add an option in the Unleashed settings:
On/Off: Do not flash RED LED when Unleashed receives VALID GPS data, no matter what source.

Why signal the user that something is wrong when GPS data is received anyways? There is something wrong BUT it still is working anyhow! The problem is not a disconnected device, but GPS data not being received by the Camera!
You should provide this Unleashed setting for those users that don't want the distraction of a RED LED flashing constantly while the Unleashed and GPS data actually is working as planned.

Greetings,
Unfoolishly
Last edited by Unfoolishly on October 11th, 2021, 3:37 am, edited 2 times in total.
Retired customer of the Unleashed. I have given up on this project, it's a never-ending story of bugs. Goodbye everyone!
Unfoolishly
Posts: 293
Joined: June 24th, 2020, 2:43 am

October 11th, 2021, 3:36 am

Could be related:
viewtopic.php?f=18&t=1127

Maybe?
Retired customer of the Unleashed. I have given up on this project, it's a never-ending story of bugs. Goodbye everyone!
Post Reply