Only Photo mode works on N2 and Nikon D750 [solved - hardware defect]

We tested as good as we can. But there will always be things we didn't find. If you found things that apparently don't work as they should, you can report them here so we can take care of them as soon as possible.
Posts: 28
Joined: November 26th, 2018, 7:01 pm

December 19th, 2018, 11:55 pm

OK, I just got a Z7 and tried putting the Unleashed on it.

First of all, the camera and the app. are more active on the Z7 than on the D750. The back screen on the Z7 is turning on and off and the haptic feedback on my iPhone is pretty active when the app. is open.

Initially, in Photo mode, the only setting which is active is GPS. I get a yellow ring and I'm able to activate the shutter and the resulting shot has GPS.

Then all the other settings except Metering, Mode, Shutter Speed become active. Camera is set on Aperture priority with Auto ISO Sensitivity on, minimum shutter 1/125. It displays ISO 64 but takes the photo at like ISO 3600. I guess it won't override the ISO Sensitivity On settings?

In any event, every few seconds, I hear something in the camera and on the app, all settings other than GPS and ISO become disabled and then again, they all become enabled. Shutter button ring alternates between white and gold.

I can actuate the shutter and it does a better job of this than the Nikon Snapbridge app, which only actuates the shutter in Wifi mode and with fewer settings available.

The main issue though is that the Video and TimeLapse modes are NOT available on the Z7 either. The same "Currently taking a photo. Wait for it to complete."

So I unplugged the Unleashed from the Z7 and put it back on the D750, only this time, I connected the USB cable as well to the camera and the Unleashed. I don't recall the exact sequence of operations I did in the Unleashed app. but Video and Time-lapse modes are available for use on the D750!

So I tried to use the app. to start a video, nothing recorded. I then switched to Time-lapse and set up a time lapse, have access to all the settings I didn't have before. I start it and see the shot counter go up and the clock spin. But my D750 I see the focus light go on but the shutter will not actuate.

I stopped the Time-lapse in the app., switch to Photo mode and try to actuate the shutter. Again the focus light on the D750 but the shutter won't go off.

So I tried disconnecting the USB end of the cable from the D750 and start Time-lapse again and the shutter is going off as expected. So the Unleashed device and app. works when the USB cable is connected to the device but not to the micro USB of the camera itself.

Then I go and reconnect the Unleashed on my Z7. I then realize that the Z7 has a USB-C port, not micro USB like the D750. So I can't find a way to get the Video or Time-lapse modes available on the Z7. I tried back and forth and can't get it to work.

Tried putting the Unleashed back on the D750 without the USB cable and the Video and Time-lapse modes are disabled. Tried connecting the cable just to the Unleashed and still can't access the Video or Time-lapse settings. So again, I connect the micro USB connector end to the camera. Verified again that I can change the Time-lapse settings and start a Time-lapse but it won't actually trigger the shutter on the D750. So I disconnect the micro USB end of the cable and now see that again, a Time-lapse run will trigger the shutter and save shots to the memory card of the D750.

It can't be sending or receiving any data through the USB cable if only one end is connected, right?

Yet to summarize, I have to first connect both ends of the USB cable on the D750 to be able to access the Video and Time-lapse modes without the "currently taking a photo" error message. Then I have to disconnect the micro USB end of the cable to get the shutter to actually trigger in Time-lapse mode.

Seems like the Unleashed device and the app. are tracking the state of whether the USB cable is plugged into the device and seems to behave differently depending on whether the cable is connected at all, or is connected on both ends, or is connected only on one end.

Initially I was mainly interested in the geotagging feature but I've been reading more on time lapse shooting so I would want to be able to use those features of the device and the app.
Posts: 28
Joined: November 26th, 2018, 7:01 pm

December 20th, 2018, 12:09 am

OK I just realized it's not a micro USB adapter.

It's some little-used Mini-B 8-pin on the one end of that cable.

Do you have a cable which will connect the Unleashed to a USB-C port on the Z7?
Posts: 418
Joined: October 9th, 2018, 4:17 pm

December 20th, 2018, 1:21 pm

Hi hyy,

Thanks for your writeup.

From what it sounds like, you have an intermittent hardware issue. The camera tells the Unleashed whether the shutter is currently open or not. This is reflected by the yellow ring around the shutter.

As you're seeing it on and off, without really changing anything, it's clearly not working as it should. (we added haptic feedback to the app whenever you're taking a photo (ie shutter opens/closes) so it's no wonder your haptic feedback is going crazy too.

This also explains your other issues: when the Unleashed app thinks you're taking a photo (yellow ring in photo mode), it blocks the other modes (Video, Timelapse, etc) since it would only cause problems if you tried to start a timelapse during a long exposure shot.

It's very weird that when you plug in the USB cable the yellow ring problem is alleviated, but it gives me an idea of how we can add a workaround for the issue in a firmware update. We will test if my idea has any negative side-effects, and if it doesn't we'll put it into the next firmware update.

The fact that the camera only focusses with the USB cable plugged in is also very weird are you sure it's able to focus, or are you just pointing the camera at a blank wall or something? can you test it with manual focus, to see if the camera triggers? we have one other customer with the same complaint, and cannot reproduce it.

Now to your Z7 specific points:
have a look at this thread, where we already discussed the going off and back on of the Z6: viewtopic.php?f=13&t=82
we have adjusted the timeout from 2 minutes to 30s in the next firmware update, so it matches the default timeout of the Z cameras, and will make this an adjustable setting in the future
when the meter goes off (briefly) the Unleashed can't communicate with the camera anymore (hence all the settings get greyed out except GPS which works differently) but since the Unleashed still wants to communicate, it wakes up the camera again.

We fixed the Auto ISO issue in the latest firmware (coming soon)

Lastly: we don't yet have a USB-C cable, but are in the process of having one made.
We do however have a Micro-USB cable, and there are plenty of Micro - USB-C adapters out there, which should work in the meantime, even if it sticks out quite a bit from the camera.
Founder & CEO of Foolography, Hardware & Firmware developer.
Posts: 28
Joined: November 26th, 2018, 7:01 pm

December 20th, 2018, 6:48 pm

First of all the high haptic activity occurs only on the Z7, not the D750, to clarify.

Second, I tried it on the D750 again, with it set to manual focus. I have it on my kitchen counter so the nearest objects it's focusing on are maybe 1-2 meters away. It's not very bright, even with lights on, so that may be why in auto focus, it was hunting.

Without the USB cable, it is difficult to get all the other settings in Photo mode accessible. It even returns the message that Unleashed was in power saving mode, tap settings to wake it up. But doing so didn't really work that well. Eventually I got it to light up the other settings. The GPS setting is always lit up and I can always trigger the shutter, whether the ring is white or gold.

And as noted before, without the USB cable, Video and Time-lapse simply do not work, still returning the status that the camera is taking a picture.

So I plugged in the USB cable. Note that I have to remove the Unleashed from the camera to plug in the USB cable at the top because there isn't room above the Unleashed when it's plugged into the camera to plug in that USB cable to the top of the Unleashed.

With the USB cable in, it seems the Photo settings light up much quicker and it's also more likely to have a gold ring than a white ring. Also, when I had it in MF mode, tapping the setting once returned that message about the camera taking a picture. But all the other settings were lit up and it was a gold ring.

And as noted, I could change the settings in TimeLapse mode, start and stop time lapses.

I don't know if it's a good workaround to plug in that USB cable to only one end and have it dangle off the camera. Maybe if you're using a flag to track whether the USB cable is plugged in, you're going down a certain code path that returns these erroneous states about the camera taking a picture or the Unleashed being in power saving mode.
Posts: 28
Joined: November 26th, 2018, 7:01 pm

December 22nd, 2018, 4:58 pm

When would the firmware update be available?

Or the cable with the micro USB?
Posts: 418
Joined: October 9th, 2018, 4:17 pm

May 21st, 2019, 3:48 pm

For you and others following this thread:
A firmware update is finally available that should fix the issue with the permanent yellow ring (blocking other modes).
Just update your app - the firmware update is included

Please let us know if this update resolves your issue!
Founder & CEO of Foolography, Hardware & Firmware developer.
Posts: 28
Joined: November 26th, 2018, 7:01 pm

July 10th, 2019, 10:11 pm

Just tried the newest firmware, 1.4.0, 1.4.2 and 1.3.0 on my D750.

Still get mostly white ring, with the only available control in photo mode being GPS. The shutter still works, but with yellow ring.

The other modes, Video, Time-lapse, are not as available as before.

Then I tried plugging in the USB cable and at first I could change the aperture and a few of the other controls lit up, presumably meaning I could adjust them. The ring was white for awhile.

Then I tried Video and Time-lapse and those still didn't work, still said "Video trigger is not available. Cameras is shooting. Wait for the shot to finish."

By the time I went back to Photo mode, the shutter ring was hello again with only GPS lit up.

Am I suppose to manually switch the camera to video mode (by sliding the Live View switch over and turning on LV)? I tried it still didn't work, but was curious if the app. was cable of switching to video mode.
Posts: 28
Joined: November 26th, 2018, 7:01 pm

July 10th, 2019, 10:19 pm

In addition, with the N2 plugged in, my D750 controls for the menus don't work at all.

Unplug it and they work, such as cycling through the shots on the card or operating the menu.

Plug it back in and they don't work.

I don't believe this occurred with the D750 under the previous firmware.

But I was having this problem with my Z7 under the old firmware.
Posts: 418
Joined: October 9th, 2018, 4:17 pm

July 11th, 2019, 11:31 am

Hi hyy,

If the firmware updates haven't made a difference until now, then you almost certainly have a defective Unleashed. We'll swap it for you. please send an email with your current billing & shipping address and a request for RMA information to

Founder & CEO of Foolography, Hardware & Firmware developer.
Posts: 1
Joined: December 3rd, 2019, 7:17 am

December 3rd, 2019, 7:23 am

Thanks for sharing this information with us and telling about the main issue which is the Video and TimeLapse modes.This information will be really helpful.
Post Reply